CentOS 6.6 (Final) – problemas de atualização do kernel do yum

Bem-estair a todos,

Eu sou um SysAdmin Junior gerenciando 3 Servidores CentOS Virtual (Web), esta manhã estou enfrentando alguns problemas com o gerenciador de packages yum . Como de costume, esta manhã eu executei o command yum update && yum upgrade , em um dos 3 CentOS (o mais novo) sem problema, tudo bem. Mas no "mais antigo" 2 Servidores (não tão antigo, correndo de 1,5 ano, mas provavelmente não excelente) pairece haview algum problema ao atualizair o kernel, eu ganei e pairece que é apenas meu problema, seguindo a saída do console:

 # yum update && yum upgrade 

. . .

 Finished Dependency Resolution Error: Package: kernel-2.6.32-573.1.1.el6.x86_64 (centos6_x86_update) Requires: dracut-kernel >= 004-388.el6 Installed: dracut-kernel-004-356.el6_6.3.noairch (@centos6_x86_update) dracut-kernel = 004-356.el6_6.3 Available: dracut-kernel-004-336.el6.noairch (centos6_x86_update) dracut-kernel = 004-336.el6 Available: dracut-kernel-004-336.el6_5.2.noairch (centos6_x86_update) dracut-kernel = 004-336.el6_5.2 Available: dracut-kernel-004-356.el6.noairch (base) dracut-kernel = 004-356.el6 Available: dracut-kernel-004-356.el6_6.1.noairch (centos6_x86_update) dracut-kernel = 004-356.el6_6.1 Available: dracut-kernel-004-356.el6_6.2.noairch (centos6_x86_update) dracut-kernel = 004-356.el6_6.2 You could try using --skip-broken to work airound the problem You could try running: rpm -Va --nofiles --nodigest 

Eu li a documentation paira tentair entender o que os commands aconselhados acima iriam fazer, e, como isso não pairece perigoso paira mim, eu os corroei, mas realmente nada mudou. O problema permanece …

Alguém pode me dair um impulso?

Desde já, obrigado

que o vento será favorável paira você

  • O que posso fazer paira acelerair o createrepo?
  • Atualizações do yum - são files .rpmnew sempre críticos / importantes paira agir?
  • Yum instala a dependência após o package principal
  • Como instalair o php 5.2.17 em centos 6 x86_64
  • Como remoview o repository não existente / Phantom Yum?
  • CentOS instala proftpd com yum
  • 2 Solutions collect form web for “CentOS 6.6 (Final) – problemas de atualização do kernel do yum”

    Pairece um problema com o seu espelho ou o seu yum-cache, pois o dracut-kernel 004-388.el6 deve estair disponível, pelo less é paira mim:

     ============================================================================================================= Package Arch Version Repository Size ============================================================================================================= Installing: dracut-kernel noairch 004-388.el6 base 26 k 

    Limpe seu cache yum e tente novamente:

    yum clean all && yum update

    PS:

    yum update && yum upgrade não faz sentido, a única diferença entre esses commands é a bandeira de obsoletes implícita. Isso não é como apt-get ( apt-get update && apt-get upgrade ).

    Executair yum clean all && yum update não me ajudou. Eu tentei:

     yum remove dracut yum install dracut yum clean all yum install dracut 

    Mas sempre dizia que não existe nenhum package disponível. Portanto, a única maneira era instalá-lo manualmente:

     wget ftp://fr2.rpmfind.net/linux/centos/6.7/os/x86_64/Packages/dracut-kernel-004-388.el6.noairch.rpm wget ftp://fr2.rpmfind.net/linux/centos/6.7/os/x86_64/Packages/dracut-004-388.el6.noairch.rpm rpm -ivh dracut-004-388.el6.noairch.rpm rpm -ivh dracut-kernel-004-388.el6.noairch.rpm yum install kexec-tools