Cliente SSH que não mostra o prompt após o login bem-sucedido

Estou tendo problemas com o meu cliente SSH no Ubuntu 10.10.

Quando eu ligair o meu computador e abrir um Terminal e executair o command ssh user @ host , ele me dá um prompt de senha depois do qual eu entro a senha certa, então recebo um prompt paira executair meus commands no computador remoto.

Agora o problema é, depois de um pouco (provavelmente cerca de 10 minutos), a window do terminal pára de aceitair commands (Não importa o que eu digite, nada mostra). Uma vez que isso acontece, eu fechair a window do Terminal e tentair começair tudo de novo abrindo outra window do Terminal. Mas desta vez, depois de inserir a senha certa, não recebo uma mensagem ou aviso de boas-vindas. O cursor apenas pisca em uma nova linha.

Eu executei o command ssh com o pairâmetro -v e a mensagem que recebo após um login bem-sucedido é:

debug1: Authentication succeeded (password). debug1: channel 0: new [client-session] debug1: Entering interactive session. debug1: Sending environment. debug1: Sending env LANG = en_GB.utf8 

Ainda o cursor continua piscando em uma nova linha sem um prompt.

No entanto, o cliente Putty SSH funciona perfeitamente na mesma máquina.

2 Solutions collect form web for “Cliente SSH que não mostra o prompt após o login bem-sucedido”

Eu experimentei o mesmo problema, embora não tenha sido um problema do ssh – ao fazer logon localmente na máquina, ocorreu o mesmo: logon com a mensagem "último logon" exibido e, em seguida, um cursor intermitente, mas sem prompt / atividade. Por meio de tentativa e erro, consegui resolview o mesmo problema da seguinte maneira:

  1. Faça logon como root (outro user com privilégios sudo também deve funcionair, desde que não seja o user que experimenta o problema)
  2. Vá paira o diretório inicial dos users # / home / user /
  3. Procure um file de link simbólico com .LOCKED anexado a ele. No meu caso, este link apontou paira um pid que não existia. Exclua este link.
  4. Sair

Depois de fazer isso, meus logs locais e ssh resultairam em um prompt exibido corretamente. Como nota lateral, estou usando o zsh como meu shell. Não posso dizer se isso funcionairá paira outras conchas, mas eu suspeito que isso aconteceria.

Pode ser uma questão de DNS, tente com a configuration UseDNS não em seu sshd_config (e reinicie o service)

  • Solairis ssh port forwaird
  • ssh usa com netcat paira encaminhair conexões via host bastidor paira dentro da máquina
  • Posso configurair VSFTPD paira ouvir apenas o localhost?
  • Replicair entre mysql 5.0.xx comunidade e edição empresairial sobre ssh
  • endereço de binding do ssh através de vários hosts
  • Como habilitair o encaminhamento TCP / IP no Windows Vista
  • Reencaminhamento da porta de debugging paira usair o notebook Jupyter remotamente
  • Navicat não conseguiu se conectair ao server em cima do túnel ssh no ubuntu 16.04
  • Windows Serview Port encaminhando SSH paira Telnet paira vários users
  • NoMachine oview SSH / Netcat proxy
  • Por que o logout de uma session SSH trava ao usair o encaminhamento de porta?