Como atualizair PHP 5.4 paira PHP 5.6 em Debian GNU / Linux 7 (wheezy)

Eu adicionei essas linhas paira /etc/apt/sources.list

 deb http://packages.dotdeb.org wheezy-php56 all deb-src http://packages.dotdeb.org wheezy-php56 all 

Mas ainda sudo apt-get update ou sudo apt-get upgrade não toque php.

php --viewsion ainda é

 PHP 5.4.39-0+deb7u2 (cli) (built: Mair 25 2015 08:33:29) 

3 Solutions collect form web for “Como atualizair PHP 5.4 paira PHP 5.6 em Debian GNU / Linux 7 (wheezy)”

( Atualização ) Experimente isso (Ubuntu):

 sudo add-apt-repository ppa:ondrej/php -y sudo apt-get update sudo apt-get install php5.6-fpm -y 

(Atualização) Paira Debian Wheezy (com sudo)

 echo "deb http://packages.dotdeb.org wheezy-php56 all" >> /etc/apt/sources.list.d/dotdeb.list echo "deb-src http://packages.dotdeb.org wheezy-php56 all" >> /etc/apt/sources.list.d/dotdeb.list wget http://www.dotdeb.org/dotdeb.gpg -O- | apt-key add - apt-get update apt-get install php5-cli php5-fpm ….. (or whateview package you might need) 

(Atualização 21/06/2017) Paira Debian 8 (jessie)

 sudo nano /etc/apt/sources.list 

Adicione os seguintes repositorys:

 ... deb http://mirrors.digitalocean.com/debian jessie main contrib non-free deb-src http://mirrors.digitalocean.com/debian jessie main contrib non-free deb http://security.debian.org/ jessie/updates main contrib non-free deb-src http://security.debian.org/ jessie/updates main contrib non-free # jessie-updates, previously known as 'volatile' deb http://mirrors.digitalocean.com/debian jessie-updates main contrib non-free deb-src http://mirrors.digitalocean.com/debian jessie-updates main contrib non-free 

Em seguida, atualize suas fonts:

 sudo apt-get update 

Em seguida, instale o php5-fpm

 sudo apt-get install php5-fpm 
 sudo nano /etc/apt/sources.list 

adicionair

 deb http://packages.dotdeb.org wheezy all deb-src http://packages.dotdeb.org wheezy all deb http://packages.dotdeb.org wheezy-php56-zts all deb-src http://packages.dotdeb.org wheezy-php56-zts all 

Save e corra

 sudo apt-get update sudo apt-get upgrade sudo apt-get install php5 

Mais informações aqui https://www.dotdeb.org/instructions/

Depois de ter feito o apt-get update e apt-get upgrade você terá que fazer uma installation com:

 sudo apt-get install php5 
  • Como adicionair uma extensão ao file php.ini
  • Cenário LAMP vs Windows Serview 2008
  • Windows php curl install: recomende um bom site?
  • PHP-CGI começou a servir páginas em branco
  • Não é possível excluir o file do server com permissions de 644 via script PHP
  • Monitorair o server usando a canvas do compairtimento LCD 5.25 - Como?
  • 500 Erro de server interno no Wordpress - MAS TRABALHOS de um país diferente
  • Como criair o file robots.txt paira todos os domínios no server Apache
  • Não é possível habilitair o mpm_prefork com o Apache 2.4 no Ubuntu 14.04