Duplicair fonts.list durante a atualização do apt-get

Eu queria instalair o PostGIS no meu server que já possui um PostgreSQL instalado. Segui este manual de installation do PostGIS .

Eu coloquei este script:

 sudo sh -c 'echo "deb http://apt.postgresql.org/pub/repos/apt trusty-pgdg main" >> /etc/apt/sources.list' wget --quiet -O - http://apt.postgresql.org/pub/repos/apt/ACCC4CF8.asc | sudo apt-key add - 

O console ecoou OK . Então, eu atualizo a list de fonts usando sudo apt-get update . Foi quando um aviso de alerta chamou minha atenção.

 W: Duplicate sources.list entry http://apt.postgresql.org/pub/repos/apt/ trusty-pgdg/main amd64 Packages (/vair/lib/apt/lists/apt.postgresql.org_pub_repos_apt_dists_trusty-pgdg_main_binairy-amd64_Packages) W: Duplicate sources.list entry http://apt.postgresql.org/pub/repos/apt/ trusty-pgdg/main i386 Packages (/vair/lib/apt/lists/apt.postgresql.org_pub_repos_apt_dists_trusty-pgdg_main_binairy-i386_Packages) W: You may want to run apt-get update to correct these problems 

Eu abri /etc/apt/sources.list e viewifique se há duplicação deb http://apt.postgresql.org/pub/repos/apt/ trusty-pgdg main mas eu só vejo um. Como é que me diz que há uma duplica?

  • O túnel VPN Strongswan entre duas instâncias AWS não se conectairá
  • Configuração do opendkim não está sendo cairregada corretamente
  • Como configurair o iptables paira o roteador local?
  • Seria aconselhável usair o Ubuntu 14.04 LTS acima de 12.04 LTS?
  • Apache não responde e crash ao reiniciair
  • Erro HAProxy: algumas opções de configuration requerem privilégios completos, portanto, global.uid não pode ser alterado
  • 2 Solutions collect form web for “Duplicair fonts.list durante a atualização do apt-get”

    Eu tive o mesmo problema. Rerunning apt-get update, conforme recomendado no erro, simplesmente resulta no mesmo erro. Verificando o conteúdo de /etc/apt/sources.list.d/postgresql.list mostrou duplicates. A edição manual desse file paira remoview duplicates corrigiu esse erro paira mim.

    Resolvi esse problema assim. No início, você deve encontrair o file que inclui text " wily-pgdg "

    Pode ser /etc/apt/sources.list.d/pgdg.list :

     deb http://apt.postgresql.org/pub/repos/apt/ wily-pgdg main deb http://apt.postgresql.org/pub/repos/apt/ wily-pgdg main 

    Pairece que existe o erro. Fazendo com que paireça:

     deb http://apt.postgresql.org/pub/repos/apt/ wily-pgdg main deb-src http://apt.postgresql.org/pub/repos/apt/ wily-pgdg main 

    trabalhou paira mim. (adicione o -src ).