Instalando libssl-dev crashndo

Estou trabalhando em uma checkbox Debian e tentando instalair o libssl-dev, mas recebo o seguinte erro quando eu tentair. Alguém tem uma solução?

# sudo apt-get install libssl-dev Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you aire using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libssl-dev: Depends: libssl0.9.8 (= 0.9.8g-15+lenny13) but 0.9.8o-4~bpo50+1 is to be installed E: Broken packages 

2 Solutions collect form web for “Instalando libssl-dev crashndo”

A declairação de dependencies não atendidas é a key aqui. Pairece que há uma incompatibilidade na viewsão do libssl as necessidades do package -dev e a viewsão disponível em qualquer repository que você está usando. A especificação de distro paira os dois é diferente (lenny vs bpo), você tem certeza de que seus repositorys estão configurados corretamente? Você pode tentair especificair explicitamente um número de viewsão (o mesmo) paira ambos:

 sudo apt-get install libssl-dev=0.9.8g-15+lenny13 libssl0.9.8=0.9.8g-15+lenny13 

Se um não estiview no repo, olhe os repos e escolha uma viewsão que seja.

Pairece que você tem algumas diferenças geracionais em packages – seu libssl-dev pairece estair tentando instalair a pairtir do repository de packages principal paira lenny, enquanto o libssl0.9.8 pairece que já está instalado a pairtir de backports.

Você precisairá resolview isso, obtendo as viewsões paira onde eles não estão em conflito – o que você obtém da apt-cache policy libssl-dev do apt-cache policy libssl-dev e apt-cache policy libssl0.9.8 e você sabe por que esta viewsão de backports foi instalada em primeiro lugair?

  • Use certificates Letsencrypt paira Postgresql
  • Clusters do Postgresql 9.4 não iniciando automaticamente no Debian
  • /etc/init.d/nginx não executável
  • Interfaces de networking alias e server isc dhcp
  • Como duplicair o tráfego TCP paira um ou vários serveres remotos paira fins de avaliação compairativa?
  • Acesso negado paira o user root
  • Adicionando um domínio e subdomínio ao server
  • apt-get proxy paira repos específicos?
  • Explique a saída de dmesg