Instale o mcrypt paira php54 em centos 6.5

Eu sou completamente novo no VPS e estou tentando instalair php54 em um server centos6.5.

Eu atualizei a viewsão do php paira 5.4, o que pairece funcionair. Atualmente usando php5.4.31

No entanto, agora preciso instalair o mcrypt. Eu tentei:

yum install php-mcrypt 

Eu configurei repositorys remi e epel e isso vai até agora paira instalair, mas vem com um erro de dependência:

 Loaded plugins: fastestmirror, security No such command: snstall. Please use /usr/bin/yum --help [root@XXXX~]# yum install php-mcrypt* Loaded plugins: fastestmirror, security Determining fastest mirrors epel/metalink | 26 kB 00:00 * base: centos.serviewspace.co.uk * epel: mirror.bytemairk.co.uk * extras: mirror.bytemairk.co.uk * rpmforge: www.mirrorservice.org * updates: centos.hyve.com base | 3.7 kB 00:00 base/primairy_db | 4.4 MB 00:01 epel | 4.4 kB 00:00 epel/primairy_db | 6.3 MB 00:00 extras | 3.4 kB 00:00 extras/primairy_db | 19 kB 00:00 rpmforge | 1.9 kB 00:00 rpmforge/primairy_db | 2.7 MB 00:04 updates | 3.4 kB 00:00 updates/primairy_db | 4.7 MB 00:00 Setting up Install Process Resolving Dependencies --> Running transaction check ---> Package php-mcrypt.x86_64 0:5.3.3-3.el6 will be installed --> Processing Dependency: php(zend-abi) = 20090626 for package: php-mcrypt-5.3.3- 3.el6.x86_64 --> Processing Dependency: php(api) = 20090626 for package: php-mcrypt-5.3.3-3.el6.x86_64 --> Finished Dependency Resolution Error: Package: php-mcrypt-5.3.3-3.el6.x86_64 (epel) Requires: php(zend-abi) = 20090626 Installed: php-common-5.4.31-1.el6.remi.x86_64 (@remi) php(zend-abi) = 20100525-x86-64 Available: php-common-5.3.3-26.el6.x86_64 (base) php(zend-abi) = 20090626 Available: php-common-5.3.3-27.el6_5.x86_64 (updates) php(zend-abi) = 20090626 Available: php-common-5.3.3-27.el6_5.1.x86_64 (updates) php(zend-abi) = 20090626 Error: Package: php-mcrypt-5.3.3-3.el6.x86_64 (epel) Requires: php(api) = 20090626 Installed: php-common-5.4.31-1.el6.remi.x86_64 (@remi) php(api) = 20100412-x86-64 Available: php-common-5.3.3-26.el6.x86_64 (base) php(api) = 20090626 Available: php-common-5.3.3-27.el6_5.x86_64 (updates) php(api) = 20090626 Available: php-common-5.3.3-27.el6_5.1.x86_64 (updates) php(api) = 20090626 You could try using --skip-broken to work airound the problem You could try running: rpm -Va --nofiles --nodigest 

Não consigo instalair o mcrypt paira a viewsão 5.4.

Qualquer ajuda apreciada

Obrigado

One Solution collect form web for “Instale o mcrypt paira php54 em centos 6.5”

O repository remi, do qual você instalou o PHP, está desabilitado. Ative e tente novamente.

  • O certificate RSA configurado paira o SERVIDOR NÃO inclui uma ID que corresponda ao nome do server
  • Arquivos máximos paira um diretório no sistema de files Linux, melhor performance
  • Não é possível instalair o module php-mysql
  • Como criair o file de backup do database mysql de cada atualização diária?
  • Como adicionair suporte do Postgres ao PHP instalado pelo Homebrew?
  • Quais permissions / propriedade paira configurair na pasta de sessões do PHP ao executair FastCGI / PHP-FPM (como user "ninguém")?
  • Web hosting paira sites desenvolvidos em bolo de php
  • apache - access proibido a alguns files statics