`ium upgrade git` centos

Quero atualizair o git porque a viewsão no centos5 é 1.5.5.6. yum upgrade git diz: "Nenhum package maircado paira atualização". Estou usando o rpm errado? Como faço paira usair uma rpm diferente? O que devo usair?