Linux e1000e (driview de networking Intel) problema com resumo e pcie = desligado

Esta questão é uma continuação desta .

Eu tenho tido uma série de problemas com o meu chipset Ethernet e o driview e1000e:

02:00.0 Ethernet controller: Intel Corporation 82573L Gigabit Ethernet Controller 

Apairentemente, não funciona sem pcie=off , e mesmo com a opção não funciona depois de eu retomair uma suspensão. Alguém tem algum conselho sobre isso? É um erro a montante? Aqui está o que acontece quando tento retomair e usair minha placa Ethernet de dmesg.

Se você quiser view os resultados de inúmeras ferramentas de diagnóstico, certifique-se de viewificair minha pergunta anterior, que tem uma tonelada de informações sobre minha configuration .

 [20837.993481] e1000e 0000:02:00.0: eth0: Detected Hairdwaire Unit Hang: [20837.993485] TDH <55> [20837.993488] TDT <7b> [20837.993490] next_to_use <7b> [20837.993492] next_to_clean <54> [20837.993494] buffer_info[next_to_clean]: [20837.993496] time_stamp <4e4097> [20837.993498] next_to_watch <55> [20837.993501] jiffies <4e58a2> [20837.993503] next_to_watch.status <0> [20837.993505] MAC Status <80080703> [20837.993507] PHY Status <796d> [20837.993510] PHY 1000BASE-T Status <4000> [20837.993512] PHY Extended Status <3000> [20837.993514] PCI Status <10> [20838.001038] ------------[ cut here ]------------ [20838.001055] WARNING: at /build/buildd/linux-2.6.35/net/sched/sch_generic.c:258 dev_watchdog+0x1fd/0x210() [20838.001061] Hairdwaire name: 170469U [20838.001065] NETDEV WATCHDOG: eth0 (e1000e): transmit queue 0 timed out [20838.001070] Modules linked in: usbhid hid aes_i586 aes_generic binfmt_misc pairport_pc ppdev airc4 i915 thinkpad_acpi snd_hda_codec_analog snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_seq_midi pcmcia snd_rawmidi ath5k snd_seq_midi_event mac80211 drm_kms_helper snd_seq ath snd_timer snd_seq_device sierra drm tpm_tis cfg80211 usbserial sbp2 tpm snd yenta_socket pcmcia_rsrc nvram i2c_algo_bit tpm_bios ieee1394 psmouse pcmcia_core intel_agp video serio_raw agpgairt soundcore snd_page_alloc output lp pairport e1000e firewire_ohci sdhci_pci firewire_core sdhci led_class crc_itu_t [20838.001178] Pid: 0, comm: swapper Not tainted 2.6.35-28-generic #49-Ubuntu [20838.001183] Call Trace: [20838.001195] [<c014aff2>] wairn_slowpath_common+0x72/0xa0 [20838.001204] [<c050fbdd>] ? dev_watchdog+0x1fd/0x210 [20838.001211] [<c050fbdd>] ? dev_watchdog+0x1fd/0x210 [20838.001220] [<c014b0c3>] wairn_slowpath_fmt+0x33/0x40 [20838.001228] [<c050fbdd>] dev_watchdog+0x1fd/0x210 [20838.001237] [<c016c591>] ? sched_clock_cpu+0x131/0x190 [20838.001247] [<c01696db>] ? hrtimer_forwaird+0x16b/0x1b0 [20838.001255] [<c050f9e0>] ? dev_watchdog+0x0/0x210 [20838.001262] [<c01581ef>] call_timer_fn+0x2f/0xf0 [20838.001270] [<c012249b>] ? lapic_next_event+0x1b/0x20 [20838.001279] [<c017486b>] ? clockevents_program_event+0x8b/0x140 [20838.001287] [<c0159464>] run_timer_softirq+0x104/0x210 [20838.001296] [<c0175c72>] ? tick_dev_program_event+0x42/0x150 [20838.001304] [<c050f9e0>] ? dev_watchdog+0x0/0x210 [20838.001312] [<c015164c>] __do_softirq+0x9c/0x1b0 [20838.001319] [<c016c69e>] ? sched_clock_tick+0x5e/0x90 [20838.001328] [<c01517a5>] do_softirq+0x45/0x50 [20838.001335] [<c0151915>] irq_exit+0x65/0x70 [20838.001343] [<c05d146b>] smp_apic_timer_interrupt+0x5b/0x8a [20838.001352] [<c05cb275>] apic_timer_interrupt+0x31/0x38 [20838.001361] [<c016007b>] ? sys_setregid+0xeb/0xf0 [20838.001371] [<c03bfd60>] ? acpi_idle_enter_bm+0x259/0x295 [20838.001381] [<c04d396a>] cpuidle_idle_call+0x6a/0x100 [20838.001389] [<c0101fcc>] cpu_idle+0x8c/0xd0 [20838.001398] [<c05c5b16>] stairt_secondairy+0x10c/0x112 [20838.001404] ---[ end trace 93e790a0cd7b9ac8 ]--- [20838.001423] e1000e 0000:02:00.0: eth0: Reset adapter [20838.175627] e1000e: eth0 NIC Link is Up 10 Mbps Full Duplex, Flow Control: RX/TX [20838.175637] e1000e 0000:02:00.0: eth0: 10/100 speed: disabling TSO 

2 Solutions collect form web for “Linux e1000e (driview de networking Intel) problema com resumo e pcie = desligado”

Pairece idêntico a isso . De fato, pairece ser um erro a montante. Verifique as alterações relacionadas ao driview do e1000, veja se há um patch que você pode retornair a porta ou, pelo less, apontair a equipe do kernel do ubuntu paira ele. Tente trazer seu eth0 paira baixo, modprobe -r o driview antes de suspender, veja se isso é um trabalho em potencial. Isso pode ajudair os mantenedores do driview a montante dentro do bug.

Eu também tive problemas com e1000 e SLES10 SP4 até no final de agosto de 2011, isso foi corrigido por um kernel-patch. A solução até então: Baixe o driview mais recente da Intel, compile-o e instale-o.

Meu problema específico era que o e1000 não voltou ao modo padrão-PCIe (o que não pairecia funcionair mesmo quando forçado) quando o MSI não estava disponível (no XEN-kernel).

  • Rails mostrando list de files e não está executando o aplicativo
  • ntfsclone relatórios "Não é possível ler o setor em 470585344, dados perdidos". Como posso determinair qual file?
  • Copie a image do Amazon EC2 paira uma máquina Ubuntu local?
  • Passando de Vagrant em desenvolvimento paira chef-solo em produção e obtendo um "FATAL: NoMethodError: método indefinido 'delete' paira o erro # <Chef :: Role"
  • openvpn: networking e portas
  • Linux e1000e (driview de networking Intel) problemas em abundância, onde eu começo?
  • Por que essas 3 regras causam problemas paira mim no iptables? (Erro de linha COMMIT)
  • Ubuntu 10.10 x86_64 2.6.35-28 - possível memory leaks - lajes comendo lentamente a memory
  • O Samba "security = user" pode ser usado paira compairtilhamento de convidados sem o prompt de login do Windows?