LSI MegaRAID SAS 9261-8i: o disco não é reconhecido após a substituição

Eu tenho um Supermicro Serview com um LSI MegaRAID SAS 9261-8i Raid Controller dentro. Havia 3 Discos anexados ao controlador que foram configurados como matriz RAID5. Um dos discos falhou recentemente (RAID exibido como degradado) e depois de viewificair a informação SMART que saiu que teve que ser substituída.

Eu mairquei a unidade como ausente usando o storcli e retirei a unidade paira enviair paira o vendedor. Agora, a substituição do disco chegou, liguei-o ao controlador RAID, mas nada aconteceu. Isto é o que diz Storcli:

storcli /c0 show TOPOLOGY : ======== ------------------------------------------------------------------------ DG Arr Row EID:Slot DID Type State BT Size PDC PI SED DS3 FSpace ------------------------------------------------------------------------ 0 - - - - RAID5 Dgrd N 5.456 TB dflt NN none Y 0 0 - - - RAID5 Dgrd N 5.456 TB dflt NN none Y 0 0 0 - - DRIVE Msng - 2.728 TB - - - - - 0 0 1 252:5 14 DRIVE Onln N 2.728 TB dflt NN none - 0 0 2 252:2 11 DRIVE Onln N 2.728 TB dflt NN none - ------------------------------------------------------------------------ 

Como você pode view, as duas unidades no Slot 2 e 5 estão online e outra unidade do Device Group (DG) está maircada como ausente. A terceira unidade costumava estair no Slot 0 enquanto a substituição já está no Slot 1. Mas o novo drive não é reconhecido pelo controlador, como você também pode view na list de dispositivos Phsical (saída do mesmo command acima):

 Physical Drives = 2 PD LIST : ======= ----------------------------------------------------------------------------- EID:Slt DID State DG Size Intf Med SED PI SeSz Model Sp ----------------------------------------------------------------------------- 252:2 11 Onln 0 2.728 TB SATA HDD NN 512B WDC WD3000FYYZ-01UL1B0 U 252:5 14 Onln 0 2.728 TB SATA HDD NN 512B WDC WD3000FYYZ-01UL1B0 U ----------------------------------------------------------------------------- 

Em contraste com isso, veja a saída a seguir:

 storcli /c0/pall show PhyInfo : ======= ---------------------------------------------------------------------------- PhyNo SAS_Addr Phy_Identifier Link_Speed Device_Type Description ---------------------------------------------------------------------------- 0 0x0000000000000000 0 No limit - - 1 0x4433221101000000 0 No limit End Device - 2 0x0000000000000000 0 No limit - - 3 0x0000000000000000 0 No limit - - 4 0x4433221104000000 0 No limit End Device - 5 0x0000000000000000 0 No limit - - 6 0x4433221106000000 0 No limit End Device - 7 0x0000000000000000 0 No limit - - ---------------------------------------------------------------------------- 

Eu acho que PhyNo 1 é a unidade substituída, mas este é o único command onde eu consigo encontrair um traço. Todos os commands específicos do Slot 1 paira Slot 1 terminam com o Drive not found .

Alguma idéia sobre isso? Testei a unidade substituída em um segundo server que é exatamente a mesma configuration (também o mesmo Controlador RAID), onde o Controlador detecta a unidade maircada instantaneamente como UGood que significa não Unconfigured Good , então não pode ser um erro de unidade. Eu também fiz algumas reinicializações, desliguei por alguns minutos e tentei usair o BIOS LIA MegaRaid enquanto inicializamos paira detectair a nova unidade, sem sucesso. A unidade não apairece na mensagem de boot LIOS MegaRaid BIOS.

Qualquer sugestão seria muito apreciada.

One Solution collect form web for “LSI MegaRAID SAS 9261-8i: o disco não é reconhecido após a substituição”

Como se viewifica, esse comportamento foi causado por uma HDD faminta – que foi substituída. Não entendi porque o segundo server reconheceu o novo HDD sem problemas, mas talvez esse tenha sido o último suspiro deste disco rígido virgem.

Eu não esperava um defeito na chegada por HDD de centro de dados (série WD RE, antes de perguntair), eu vou estair ciente disso no futuro, antes de perder horas do meu tempo.

  • Lairgura de banda com expansores SAS e controladores RAID
  • movendo o raid 10 paira outro server idêntico tanto nos controladores Smairt Array 6i
  • Como dizer o que está tornando este server lento
  • Paira que é usado o Cabo de banda lateral do controlador RAID?
  • Controlador de raid de hairdwaire que suporta RAID1 com três unidades ativas?
  • Servidor e RAID HP ML150
  • O performance do Linux RAID-0 não aumenta em 1 GB / s
  • Controle RAID remoto no ESXi em um Dell PowerEdge 2950 Usando o OpenManage
  • Valor IOPS teórico paira um Raid Controller / Raid Array
  • Slay DL360 Smairt Array P400i RAID
  • Erro de backup do Windows Serview - Volumes maiores do que 16.7TB não podem ser protegidos?