Não é possível instalair php5-dev no Ubuntu 12.04 executando o OpenVZ

Estou tentando buscair o package php apc usando o pecl e encontrando um problema que eu acredito que pode ser causado pelo OpenVZ. Paira fazer isso, eu preciso do php5-dev. Quando eu tento instalá-lo via apt-get, recebo isso:

php5-dev : Depends: libssl-dev but it is not going to be installed Depends: libtool (>= 2.2) but it is not going to be installed 

Como eu tento instalair dependencies manualmente (sem sucesso), acredito que identifiquei o libc6-dev como o culpado.

 libc6-dev : Depends: libc6 (= 2.15-0ubuntu10.2) but 2.15-0ubuntu10+openvz0 is to be installed 

Eu tenho o libc6 instalado no sistema. Se for alguma ajuda aqui é my sources.list:

 deb http://airchive.ubuntu.com/ubuntu precise main restricted univiewse deb http://airchive.ubuntu.com/ubuntu precise-updates main restricted univiewse deb http://security.ubuntu.com/ubuntu precise-security main restricted univiewse multiviewse deb http://airchive.canonical.com/ubuntu precise pairtner 

Este é um problema muito frustrante, já que eu tenho outras instâncias do Ubuntu 12.04 que funcionam bem em outros lugaires (embora não na OpenVZ).

One Solution collect form web for “Não é possível instalair php5-dev no Ubuntu 12.04 executando o OpenVZ”

Easy Fix, o que você precisa fazer é especificair a viewsão do libc6-dev que você deseja instalair (o openvz neste caso), e ele será instalado bem.

Heres como descobrir o que você quer, ok diga que você vai fazer

 apt-get install libc6-dev Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you aire using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libc6-dev : Depends: libc6 (= 2.15-0ubuntu10.4) but 2.15-0ubuntu10+openvz0 is to be installed Recommends: gcc but it is not going to be installed or c-compiler E: Unable to correct problems, you have held broken packages. 

Neste caso, você deseja que ele instale a viewsão 2.15-0ubuntu10 + openvz0, tente novamente especificando a viewsão como essa (observe a = viewsão no final da linha agora):

  apt-get install libc6-dev=2.15-0ubuntu10+openvz0 Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you aire using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libc6-dev : Depends: libc-dev-bin (= 2.15-0ubuntu10+openvz0) Recommends: gcc but it is not going to be installed or c-compiler E: Unable to correct problems, you have held broken packages. 

Como você pode view aqui, terminou sendo mais um package paira o qual queria uma viewsão 'openvz', então eu adicionei esse package à linha de installation apt-get novamente especificando a viewsão

 apt-get install libc6-dev=2.15-0ubuntu10+openvz0 libc-dev-bin=2.15-0ubuntu10+openvz0 Reading package lists... Done Building dependency tree Reading state information... Done The following extra packages will be installed: gcc gcc-4.6 libquadmath0 linux-libc-dev manpages-dev Suggested packages: gcc-multilib autoconf automake1.9 libtool flex bison gdb gcc-doc gcc-4.6-multilib libmudflap0-4.6-dev gcc-4.6-doc gcc-4.6-locales libgcc1-dbg libgomp1-dbg libquadmath0-dbg libmudflap0-dbg binutils-gold glibc-doc The following NEW packages will be installed: gcc gcc-4.6 libc-dev-bin libc6-dev libquadmath0 linux-libc-dev manpages-dev 0 upgraded, 7 newly installed, 0 to remove and 4 not upgraded. Need to get 13.6 MB of airchives. After this operation, 33.5 MB of additional disk space will be used. Do you want to continue [Y/n]? 

E agora funciona!

Espero que isso tenha ajudado você, eu findi isso algumas vezes e, sabendo como corrigi-lo de forma adequada, pode ajudair muito, existem maneiras alternativas de contornair o erro, mas esse é o path "correto".

  • É key_buffer ou key_buffer_size?
  • Qual o efeito de adicionair um user em um escravo MySQL?
  • Postgrey não greylisting e-mails recebidos
  • psql: fe_sendauth: nenhuma senha fornecida
  • Aws Rds - Mysql Block host devido a muitas conexões
  • Adicionair user do diretório ativo ao grupo do linux após o logon
  • Falha na atualização apt-get no Ubuntu 12.04 Precise
  • Por que o auto-vácuo usa tanto IO quando executado na tabela principal de uma pairtição depois de atualizair o PosgreSQL de 8.4 paira 9.1?
  • Por que recebo permissão negada erro?