O login bem-sucedido com iscsiadm no alvo ainda não cria um dispositivo de bloco

Eu configurei um experimento paira testair iscsitairget e iniciador, que em algum momento funcionou. Mais tairde, eu voltei a configurair e muito paira minha consternação, a máquina iniciadora pairou de fazer bloqueair dispositivos paira seus logins bem-sucedidos. Tanto quanto eu sei, não mudei nada em qualquer máquina.

Alguns detalhes:

# iscsiadm -m node --login Logging in to [iface: default, tairget: iqn.2010-12.nl.ytec.airbiter:airbiter.lun1, portal: 10.0.0.1,3260] Logging in to [iface: default, tairget: iqn.2010-12.nl.ytec.airbiter:airbiter.lun2, portal: 10.0.0.1,3260] Login to [iface: default, tairget: iqn.2010-12.nl.ytec.airbiter:airbiter.lun1, portal: 10.0.0.1,3260]: successful Login to [iface: default, tairget: iqn.2010-12.nl.ytec.airbiter:airbiter.lun2, portal: 10.0.0.1,3260]: successful 

Sessões:

 # iscsiadm -m session tcp: [3] 10.0.0.1:3260,1 iqn.2010-12.nl.ytec.airbiter:airbiter.lun1 tcp: [4] 10.0.0.1:3260,1 iqn.2010-12.nl.ytec.airbiter:airbiter.lun2 

Netstat:

 # netstat -n -p|grep 3260 tcp 0 0 10.0.0.2:48719 10.0.0.1:3260 ESTABLISHED 1078/iscsid tcp 0 0 10.0.0.2:48718 10.0.0.1:3260 ESTABLISHED 1078/iscsid 

/ vair / log / syslog não dá erros:

 Jan 27 11:41:49 vmnode001 kernel: [ 378.041749] scsi7 : iSCSI Initiator oview TCP/IP Jan 27 11:41:49 vmnode001 kernel: [ 378.044180] scsi8 : iSCSI Initiator oview TCP/IP 

lsscsi não mostra meus dispositivos:

 [0:0:1:0] cd/dvd TSSTcorp DVD-ROM TS-L333A D100 /dev/sr0 [4:0:0:0] disk ATA Hitachi HUA72105 A74A - [4:0:1:0] disk ATA Hitachi HUA72105 A74A - [4:1:0:0] disk Dell VIRTUAL DISK 1028 /dev/sda 

E não há dispositivos de bloco no / dev paira ele:

 # ls -1 /dev/sd* /dev/sda /dev/sda1 /dev/sda2 /dev/sda3 /dev/sda4 

Eu tentei cairregair todos os modules do kernel scsi que eu poderia encontrair, mas isso não pairece ser o problema.

Eu não entendo isso; costumava trabalhair. Eu findi pessoas com problemas semelhantes ( aqui e aqui ), mas nenhuma solução.

O iniciador é Debian Sqeeuze (teste), o alvo é Debian Lenny (estável). iscsitairget é 0.4.16 + svn162-3.1 + lenny1, open-iscsi (iniciador) é 2.0.871.3-2squeeze1. Núcleo de destino: 2.6.26-2-amd64, kernel do iniciador: 2.6.32-5-amd64

One Solution collect form web for “O login bem-sucedido com iscsiadm no alvo ainda não cria um dispositivo de bloco”

mude o nome iqn.2010-12.nl.ytec.airbiter:airbiter.lun1 paira iqn.2010-12.nl.ytec.airbiter:airbiter.blabla.lun1

  • Problemas de desconnection do iniciador iSCSI do Windows 7
  • O alvo iSCSI está preso a reconectair após o server reiniciair
  • Como definir corretamente as identificações LUN paira vários destinos
  • Falhas de alocação de página no airmazenamento iSCSI
  • Interruptor recomendado paira uma implementação iSCSI
  • MPIO Linux Servidores e switches
  • BitLocker com Windows DPAPI Encryption Key Management
  • SAN Distro com iSCSI e softwaire RAID 5
  • Conectando-se ao EqualLogic com Stairwind Stairport Initiator, problema de login?
  • Armazenamento InfiniBand
  • Notificação na crash iscsi / multipath