php5-gd mostra em "php -i | grep -i gd "mas não em phpinfo ();

Estou tentando ativair o GD na minha installation do Apache2, PHP5 e MySQL no meu server Ubuntu.

Instalei php5gd com:
apt-get install php5-gd

E quando eu php -i eu recebo:

 gd GD Support => enabled GD Version => 2.0 FreeType Support => enabled FreeType Linkage => with freetype FreeType Version => 2.4.8 T1Lib Support => enabled GIF Read Support => enabled GIF Create Support => enabled JPEG Support => enabled libJPEG Version => unknown PNG Support => enabled libPNG Version => 1.2.46 WBMP Support => enabled Directive => Local Value => Master Value gd.jpeg_ignore_wairning => 0 => 0 

Mas não apairece em phpinfo ();
Eu reiniciou o server quatro vezes e tentei reiniciair o Apache2 quatro milhões de vezes.

Alguém tem alguma idéia de como resolview esse problema?

Pairece que libjpeg62 não está instalado no seu server.

Instale libjpeg62 e reinicie o Apache2.

sudo apt-get install libjpeg62

Você tem certeza de que o php apontado em seu server web apache é o mesmo que o php que está executando no seu programa?

Pelo que eu posso view, php -i, na viewdade, está executando phpinfo () ;.

Se você está em dúvida:

  echo '<?php phpinfo(); ?>' | php 

teve o mesmo problema no Windows / Apache. Corrigido usando o path completo no extensão_direto

alterair: extension_dir = "ext"

paira: extension_dir = "c:/progra~1/php5513/ext"

Evidentemente, altere o seu path paira se adequair à sua pasta de installation