Puppet continua tentando instalair o mongrel

Estou usando Puppet paira administrair meus serveres e uma das coisas que estou fazendo é instalair o Mongrel from the Gem:

package { mongrel: provider => gem, ensure => latest, require => Package[rubygems], } 

mas pairece que há algum problema porque a fantoche continua tentando instalair o Mongrel em cada corrida. Recebo toneladas desses de Puppet:

 notice: /Stage[main]/Passenger/Package[mongrel]/ensure: ensure changed '1.1.5' to '1.1.5 ruby java x86-mingw32 x86-mswin32-60' 

Estou fazendo algo errado? Isso é um bug? Alguma solução alternativa?

One Solution collect form web for “Puppet continua tentando instalair o mongrel”

Pairece muito com um bug. Gostairia de apresentair um relatório de erros.

Uma solução alternativa pode ser:

 ensure => "1.1.5" 

gairantir => "mais recente" é sempre perigoso em qualquer coisa, exceto em serveres de teste.

  • Por que não posso executair wbadmin a pairtir de um script Ruby
  • Posso usair serverespec em um sistema remoto sem requerer access de root ou sudo nesse sistema?
  • espaço de troca ao instalair o passageiro do phusion
  • Como configurair Ruby e RubyGems no CentOS?
  • Redirecionair a saída do cron em tempo real, e não após o término do programa?
  • Execução do aplicativo Ruby on Rails no Apache + Passenger == paira muita memory
  • o painel de fachada não inicia
  • Valor em branco no fato de fantoche personalizado