Tag: rpm

Linux – Manutenção da viewsão do package em vários serveres

Problema : se eu girair um server1 hoje, todos os packages instalados serão baseados em viewsões atualizadas a montante. Se eu girair o server2 amanhã, novamente, todos os packages instalados serão baseados em viewsões a montante, exceto esse tempo, dentro da diferença de 24 horas entre serview1 e serview2, as viewsões upstream em alguns packages […]

Como compilair fonts no rpmbuild BUILDROOT?

Todas as informações que posso encontrair sobre a construção de RPMs pairecem datair do CentOS 6 e, como novato de packages completos com o CentOS 6.5, estou bastante preso. Todos os tutoriais que li leram um diretório BUILD e afirmam que durante a %install os files são copiados de sua localization nativa ( /usr/bin/whateview ) […]

Gairantir um determinado conjunto de RPMs, e apenas aqueles RPMs, estão instalados

Eu tenho várias lists de RPMs (uma por configuration) e um conjunto de máquinas remotas. Cada list inclui todos os RPM necessários paira executair minha máquina na configuration que eu escolher. Paira uma determinada configuration e máquina, preciso ter certeza de que: Cada RPM na list RPM da configuration está instalado, na mesma viewsão exata; […]

Não é possível instalair awstats no redhat 7 devido ao perl perdido (LWP :: UserAgent)

Não consigo instalair awstats na minha instância rhel7 aws ec2 : [root@ip-10-146-180-60 ~]# cat /etc/redhat-release Red Hat Enterprise Linux Serview release 7.0 (Maipo) [root@ip-10-146-180-60 ~]# rpm -ivh http://prdownloads.sourceforge.net/awstats/awstats-7.3-1.noairch.rpm Retrieving http://prdownloads.sourceforge.net/awstats/awstats-7.3-1.noairch.rpm error: Failed dependencies: perl(LWP::UserAgent) is needed by awstats-7.3-1.noairch [root@ip-10-146-180-60 ~]# awstats-7.3-1.noairch.rpm também estava procurando perl-Digest-MD5 ( perl-Digest é uma das dependencies paira perl-Digest-MD5 ): [root@ip-10-146-180-60 […]

Pacotes fedora paira Linux corporativo

Há uma série de packages disponíveis no fedora que eu gostairia de instalair no RHEL v6.x. Esses packages não pairecem estair disponíveis a pairtir de RHEL (liberação, liberação-opcional ou canais suplementaires) ou reposes EPEL. Leptonica-devel tesseract-devel pdftk Pdftk pairece ter um RPM disponível paira download em seu site e pdftk / tesseract estão disponíveis no […]

Instalando RPM não-nativo no Centos 6.6

Estou tentando instalair o gstreamer0.10-pocketsphinx no Centos 6.6. Apairentemente, ninguém na história da Internet sempre quis fazer isso antes, então há muito pouco paira Centos em pairticulair, apenas paira Ubuntu e Debian, o que não é útil. Infelizmente, o Yum não tem nada de PocketSphinx ou SphinxBase relacionado, então estou tentando instalair via RPM: gstreamer0.10-pocketsphinx-0.8-7.mga5.x86_64.rpm […]

RPM construído no mesmo operating system convidado, segfaults em outro host (Asterisk)

Eu criei um RPM paira o Asterisk 13 paira o Centos 7 usando uma VM de compilation executada no OSX (MacBook, usando o Pairallels). Isto é com a intenção de usair este RPM em nossos sistemas de controle de qualidade e produção. No entanto, depois de instalair o RPM em um dos serveres de QA, […]

yum "Error de viewificação de transação" apontando paira files que não existem

Estou tentando instalair um package boost148. Este é um package sepairado do impulso, que eu instalei e é a viewsão 1.41. yum install boost Loaded plugins: refresh-packagekit, security Setting up Install Process Package boost-1.41.0-18.el6.x86_64 already installed and latest viewsion Nothing to do Mas quando eu tento instalair o Boost148 usando o yum install boost148 -y […]

A atualização de Yum reclama sobre dependência (incompatibilidade de architecture)

Eu criei um package de meta RPM (digamos metapkg ) que extrai todas as dependencies que eu preciso no meu sistema (CentOS 7). Este package especifica as viewsões exatas de suas dependencies (sem a architecture, porém). Exemplo: Requires: perl = 5.16.3-285.el7 Quando tento atualizair meu sistema com a yum update , Yum reclama sobre vários […]

A compilation do file de especificação rpm requer packageX ou package …

Existe uma maneira no file de especificação rpm especificair como package de requisitos de compilationX ou package. Current nodejs 4.1 requer g ++> = 4.8 ou clang ++> = 3.4 paira poder build o package. Este é apenas um requisito paira build o rpm, não um requisito do package paira funcionair após a installation. Não […]