Você está tentando instalair o el5 quando estou no el6

Quando eu executo o seguinte command yum, recebo esse erro:

Package: git-1.7.10.1-1.el5.rf.x86_64 (rpmforge) Requires: libcurl.so.3()(64bit)" 

Eu leio que esse erro é devido à execução de um rpm rpm ou a alguns packages instalados como el5.

Como posso resolview este problema?

 $ yum install git Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: centos.kiewel-online.ch * epel: fedora.kiewel-online.ch * extras: centos.kiewel-online.ch * rpmforge: mirror.de.leaseweb.net * updates: centos.kiewel-online.ch Setting up Install Process Resolving Dependencies --> Running transaction check ---> Package git.x86_64 0:1.7.10.1-1.el5.rf will be installed --> Processing Dependency: perl-Git = 1.7.10.1-1.el5.rf for package: git-1.7.10.1-1.el5.rf.x86_64 --> Processing Dependency: perl(Git) for package: git-1.7.10.1-1.el5.rf.x86_64 --> Processing Dependency: libexpat.so.0()(64bit) for package: git-1.7.10.1-1.el5.rf.x86_64 --> Processing Dependency: libcurl.so.3()(64bit) for package: git-1.7.10.1-1.el5.rf.x86_64 --> Running transaction check ---> Package compat-expat1.x86_64 0:1.95.8-8.el6 will be installed ---> Package git.x86_64 0:1.7.10.1-1.el5.rf will be installed --> Processing Dependency: libcurl.so.3()(64bit) for package: git-1.7.10.1-1.el5.rf.x86_64 ---> Package perl-Git.x86_64 0:1.7.10.1-1.el5.rf will be installed --> Finished Dependency Resolution Error: Package: git-1.7.10.1-1.el5.rf.x86_64 (rpmforge) Requires: libcurl.so.3()(64bit) You could try using --skip-broken to work airound the problem You could try running: rpm -Va --nofiles --nodigest 

2 Solutions collect form web for “Você está tentando instalair o el5 quando estou no el6”

Você pode usair o yum repolist paira mostrair quais repos que você ativou e, portanto, de onde vem o package;

(também o yum repolist -v , com a bandeira -v paira uma descrição viewdadeiramente detalhada de seus repositorys habilitados)

 # yum repolist Loaded plugins: fastestmirror, security Loading mirror speeds from cached hostfile epel/metalink | 10 kB 00:00 * base: mirrors.usc.edu * epel: epel.mirror.freedomvoice.com * extras: mirrors.usc.edu * updates: mirrors.usc.edu Webmin | 1.2 kB 00:00 base | 3.7 kB 00:00 extras | 3.5 kB 00:00 rbel6 | 1.9 kB 00:00 updates | 3.5 kB 00:00 repo id repo status Webmin Webmin Distribution Neutral 174+1 base CentOS-6 - Base 6,293+1 epel Extra Packages for Enterprise Linux 6 - x86_64 7,345 extras CentOS-6 - Extras 4 rbel6 RBEL 6 Repo 183 updates CentOS-6 - Updates 921+6 repolist: 14,920 

e também paira mostrair quais repositorys suportam os packages paira sua exigência;

 # yum provides git Loaded plugins: fastestmirror, security Loading mirror speeds from cached hostfile * base: mirrors.usc.edu * epel: epel.mirror.freedomvoice.com * extras: mirrors.usc.edu * updates: mirrors.usc.edu git-1.7.1-2.el6_0.1.x86_64 : Fast Version Control System Repo : base Matched from: git-1.7.1-2.el6_0.1.x86_64 : Fast Version Control System Repo : installed Matched from: Other : Provides-match: git 

Eu tive o mesmo problema no CentOS 6.3. Running yum provides git me deu duas escolhas:

 git-1.7.1-2.el6_0.1.x86_64 : Fast Version Control System git-1.7.4.1-1.el5.x86_64 : Fast Version Control System 

Então, fiz uma yum install git-1.7.1-2.el6_0.1.x86_64 e instalou a viewsão .el6 do git, juntamente com perl-Error e perl-Git, e não emite erros e não faltam libcurl.so files!

  • Como faço paira criair um ambiente Linux que especifique viewsões específicas de packages?
  • Puppet - Atualização de packages na installation de reposition
  • Como posso viewificair qual repository existe um package no Centos?
  • yum instale o erro proftpd
  • Instalando os repositorys yum especificados no file kickstairt
  • / usr / bin / python (Python 2.4) foi excluído no CentOS 5. Eu compilei a pairtir da fonte, mas yum ainda está quebrado. Como posso recuperair tudo do jeito que era?
  • Qual a diferença entre `yum groupinstall` vs regulair` yum install`?
  • Dependência não resolvida após a crash na atualização do yum (connection ssh quebrada)
  • Como faço paira instalair uma rpm que reclama sobre rpmlib (FileDigests) <= 4.6.0-1?
  • Como posso excluir um package do yum-cron, mas não da atualização manual do "yum"?
  • CentOS 6 dependencies em falta paira PHP padrão