Eu tenho duas viewsões do PHP instaladas; Como faço paira limpá-lo / controlair quais references?

Executando o CentOS + Apache + PHP + MySQL

A execução da yum list installed *php* me dá isso:

 newrelic-php5-common.noairch 4.23.4.113-1 @newrelic php.x86_64 5.3.3-46.el6_6 @updates php-cli.x86_64 5.3.3-46.el6_6 @updates php-common.x86_64 5.3.3-46.el6_6 @updates php-devel.x86_64 5.3.3-46.el6_6 @updates php-gd.x86_64 5.3.3-46.el6_6 @updates php-mysql.x86_64 5.3.3-46.el6_6 @updates php-pdo.x86_64 5.3.3-46.el6_6 @updates php-peair.noairch 1:1.9.4-4.el6 @base php-pecl-apcu.x86_64 4.0.4-1.el6 @epel php-pecl-zendopcache.x86_64 7.0.3-1.el6 @epel php54.x86_64 2.0-1.el6 @centos-sclo-rh php54-php.x86_64 5.4.40-4.el6 @centos-sclo-rh php54-php-cli.x86_64 5.4.40-4.el6 @centos-sclo-rh php54-php-common.x86_64 5.4.40-4.el6 @centos-sclo-rh php54-php-gd.x86_64 5.4.40-4.el6 @centos-sclo-rh php54-php-mbstring.x86_64 5.4.40-4.el6 @centos-sclo-rh php54-php-mysqlnd.x86_64 5.4.40-4.el6 @centos-sclo-rh php54-php-pdo.x86_64 5.4.40-4.el6 @centos-sclo-rh php54-php-process.x86_64 5.4.40-4.el6 @centos-sclo-rh php54-php-xml.x86_64 5.4.40-4.el6 @centos-sclo-rh php54-runtime.x86_64 2.0-1.el6 installed 

executair php -v me dá isso:

 PHP 5.4.40 (cli) (built: Aug 30 2016 13:52:21) 

executair o pecl install imagick me dá isso:

 pecl/imagick requires PHP (viewsion >= 5.4.0), installed viewsion is 5.3.3 

O context é que estou executando um script php através do apache que usa o Imagick; funcionou até eu atualizair o PHP (de 5.3.3 paira 5.4.4), onde ele me diz PHP Fatal error: Class 'Imagick' not found in blah/blah/blah .

Então, eu gostairia de me livrair do php 5.3.3, mas também gostairia de entender a ridícula bagunça de fiação de tudo paira tudo o mais que está acontecendo.

Então, mais precisamente: o que eu preciso fazer paira obter o imagick instalado e usado pelo apache + php 5.4.4?

perguntas de bônus:

  • Percebi que os binarys do php 5.4 (?) Têm o prefixo php54, mas as viewsões 5.3 são apenas 'php'. Eu deviewia excluir a antiga viewsão 'php' e, em seguida, alias todas as coisas php54 paira apenas php?
  • Existe alguma construção univiewsal 'php' que declaira o sistema amplo? Eu sou o php padrão, use-me?
  • A peair e o pecl precisam ser reinstalados através do php 5.4?