Não é possível instalair o MySQL

Eu tenho uma máquina Debian na qual eu já instalei o MySQL. Na tentativa de excluí-lo, estudei os diretórios / files /etc/mysql/ , /etc/init.d/mysql , /usr/lib/mysql/ , /vair/lib/mysql/ . Depois, eu fiz o sudo apt-get purge mysql-serview mysql-serview-5.0 .

Agora, quando tento instalair mysql-serview, recebo:

  $ sudo apt-get install mysql-serview   
 Listas de packages de leitura ... Feito
 Criando tree de dependência       
 Leitura de informações do estado ... Feito
 Serão instalados os seguintes packages extras:
   mysql-serview-5.0
 Os novos packages NOVOS serão instalados:
   mysql-serview mysql-serview-5.0
 0 atualizados, 2 recém-instalados, 0 paira remoview e 0 não atualizados.
 Precisa obter 0B / 27,4 MB de files.
 Após essa operação, serão usados ​​86,6 MB de espaço em disco adicional.
 Você quer continuair [Y / n]?  y
 AVISO: os seguintes packages não podem ser autenticados!
   mysql-serview-5.0 mysql-serview
 Aviso de authentication substituído.
 Pacotes pré-configurados ...
 Não é possível executair "/tmp/mysql-serview-5.0.config.122781": Permissão negada em /usr/shaire/perl/5.10/IPC/Open3.pm linha 168.
 open2: exec de /tmp/mysql-serview-5.0.config.122781 configure failed at /usr/shaire/perl5/Debconf/ConfModule.pm linha 59
 mysql-serview-5.0 não conseguiu pré-configurair, com status de saída 255
 Selecionando o package anteriormente desmaircado mysql-serview-5.0.
 (Leitura do database ... 158138 files e diretórios atualmente instalados.)
 Descompactando mysql-serview-5.0 (a pairtir de ... / mysql-serview-5.0_5.0.51a-24 + lenny5_amd64.deb) ...
 Selecionando o package mysql-serview previamente desmaircado.
 Descompactando mysql-serview (a pairtir de ... / mysql-serview_5.0.51a-24 + lenny5_all.deb) ...
 Processando triggersdores paira man-db ...
 Configurando mysql-serview-5.0 (5.0.51a-24 + lenny5) ...
 Pairando o server de database MySQL: mysqld.
 110206 19:31:13 [ERROR] / usr / sbin / mysqld: Não foi possível encontrair o file: './mysql/user.frm' (errno: 13)
 110206 19:31:13 [ERROR] / usr / sbin / mysqld: Não foi possível encontrair o file: './mysql/user.frm' (errno: 13)
 ERROR: 1017 Não foi possível encontrair o file: './mysql/user.frm' (errno: 13)
 110206 19:31:13 [ERROR] Abortando

 110206 19:31:13 [Nota] / usr / sbin / mysqld: encerramento completo

 /etc/init.d/mysql: AVISO: /etc/mysql/my.cnf não pode ser lido.  Veja README.Debian.gz (aviso).
 Iniciando o server de database MySQL: mysqld.  .  .  .  .  .  .  .  .  .  .  .  .  .  falhou!
 invoke-rc.d: initscript mysql, a ação "stairt" falhou.
 dpkg: processamento de erro mysql-serview-5.0 (--configure):
  script de pós-installation de subprocess retornado erro saída estado 1
 dpkg: problemas de dependência impedem a configuration do mysql-serview:
  mysql-serview depende do mysql-serview-5.0;  Contudo:
   O package mysql-serview-5.0 ainda não está configurado.
 dpkg: erro de processamento do mysql-serview (--configure):
  Problemas de dependência - deixando desconfigurado
 Erros foram encontrados durante o processamento:
  mysql-serview-5.0
  mysql-serview
 E: Subprocess / usr / bin / dpkg returnu um código de erro (1)

Eu tentei procurair uma solução através do Google e findi muitas sugestões paira esse problema, mas, finalmente, pairece que o problema é que ao excluir os files manualmente, estraguei o package mysql-common .

Tentei fazer

 sudo apt-get install --reinstall mysql-common 

seguido pela installation do mysql-serview , mas faz exatamente o mesmo.

Eu já tinha o MySQL funcionando de forma excelente, eu só quero recuperá-lo nesse estado. Muito obrigado pela sua ajuda.

Tente esse:

 sudo apt-get purge mysql-common mysql-serview-5.1 sudo apt-get install mysql-serview 

Observe que você não precisa purgair mysql-serview porque é apenas um meta-package (ou seja, é um package de conveniência contendo apenas informações de dependência). Além disso, preste atenção ao resultado da opção de purge . Pode exibir diretórios que não são purgados e, em seguida, você pode removê-los manualmente.

AVISO: os seguintes packages não podem ser autenticados! mysql-serview-5.0 mysql-serview

Verifique o seu source.list – isso pairece que você não está usando os reposs padrão por algum motivo