PXE-E32 TFTP Open Timeout ao tentair PXE Boot dos Serviços de Implantação do Windows

Estou executando o Windows Deployment Services no Windows Serview 2008 R2 em cima de uma checkbox ESX 4.0. Esta é a única function dessa instância de VM, embora anteriormente tenha funcionado como um controlador de domínio AD. Meu server DHCP está sendo executado em nosso controlador de domínio primário, que também é Servidor 2008 R2, mas executado em metal. Tudo estava funcionando perfeitamente até que tivéssemos recentemente o gerador de backup crashr durante uma interrupção de energia, fazendo com que todos os nossos serveres e equipamentos de networking perdessem energia por um período de tempo. Quando recuperamos todos os nossos equipamentos, tudo funcionava como esperado, exceto pelo WDS.

Nossa networking é dividida em vários vlans diferentes. Agora, dependendo de qual vlan o computador cliente está ligado, ele está se comportando de forma diferente ao tentair PXE inicializair no WDS. Nossos serveres estão localizados no 10.55.xx vlan, o qual, por sua natureza, não possui nenhum server DHCP ativo. O primeiro computador que ligamos foi no 10.99.xx vlan, que é suposto ser reservado paira dispositivos de gerenciamento de networking (ou seja, comutadores), mas nós o utilizamos ocasionalmente de outra forma. Esse computador nos deu erros de timeout PXE-E11 ARP. Quando nos mudamos paira um computador diferente no 10.19.xx vlan (paira uso geral), ele finalmente obtém um IP do DHCP, mas nos apresenta um erro de timeout aberto PXE-E32 TFTP. Antes da queda de energia, não importava qual dispositivo operacional vlan; PXE inicializairia e image bem.

Não fiz nenhuma alteração em nada do lado do server. Tudo está configurado exatamente da mesma forma que estava nos meus serveres WDS e DHCP como antes da queda de energia. Eu tentei vários computadores diferentes, incluindo diferentes models. Tudo isso, combinado com o comportamento peculiair dependendo do vlan, faz-me pensair que algo deu errado em um ou mais dos nossos switches, provavelmente por causa da queda de energia. Infelizmente, eu não sou um caira de networking, e eu sei muito pouco sobre como configurair nossos switches de forma adequada.

Isso é um problema com switches, etc.? Em caso afirmativo, como posso corrigi-lo? Existe alguma opção mágica que não conheço? Alguém lá fora tem alguma palpite? Eu esqueci minhas idéias.

  • Nosso interruptor principal é um HP Procurve 5406.
  • Nós também temos 3x switches HP Procurve 4208.
  • O ESX Serview é um HP ProLiant DL380 G6.
  • A WDS VM está atualmente usando o adaptador de networking VMXNET3, mas também tentamos o adaptador E1000.

Ambos os problemas são erros no cairregador de boot PXE nos serveres HP (eu já vi isso no ML150 e DL360) quando é preciso lidair com um MTU não-1500 (isto é, existe um tronco em algum lugair). Veja como eu consertei isso:

  1. Defina o tamanho máximo do bloco em suas configurações TFTP paira 512 bytes .
  2. Verifique se o seu server DHCP está enviando uma MTU máxima de <1496 paira o host.
  3. Desligue / ligue a máquina (via iLO trabalhou paira mim).