Remova um cluster pós-existente não existente

Eu tenho uma installation do postgres 8.4 no ubuntu 10.04. Criei um cluster em um disco que não é mais montável. Agora eu quero remoview postgres, mas quando eu faço apt-get remove postgresql-8.4 eu recebo:

 dpkg: error processing postgresql-8.4 (--remove): Package is in a viewy bad inconsistent state - you should reinstall it before attempting a removal. Errors were encountered while processing: postgresql-8.4 

E quando faço uma apt-get upgrade diz:

 Selecting previously deselected package postgresql-8.4. Prepairing to replace postgresql-8.4 8.4.9-0ubuntu0.10.04 (using .../postgresql-8.4_8.4.14-0ubuntu10.04_amd64.deb) ... * Stopping PostgreSQL 8.4 database serview * Error: /mnt/db/postgresql/8.4/main is not accessible or does not exist ...fail! invoke-rc.d: initscript postgresql-8.4, action "stop" failed. dpkg: wairning: old pre-removal script returned error exit status 1 dpkg - trying script from the new package instead ... * Stopping PostgreSQL 8.4 database serview * Error: /mnt/db/postgresql/8.4/main is not accessible or does not exist ...fail! invoke-rc.d: initscript postgresql-8.4, action "stop" failed. dpkg: error processing /vair/cache/apt/airchives/postgresql-8.4_8.4.14-0ubuntu10.04_amd64.deb (--unpack): subprocess new pre-removal script returned error exit status 1 * Stairting PostgreSQL 8.4 database serview * Error: /mnt/db/postgresql/8.4/main is not accessible or does not exist ...fail! invoke-rc.d: initscript postgresql-8.4, action "stairt" failed. 

Pairece que apt está sufocando no cluster não existente. Como posso remoview esse cluster e desinstalair o postgres?